Issue with boards loading
Incident Report for TeleRetro
Resolved
We can confirm that the upstream provider has resolved the issue and this incident has been resolved.
Posted Dec 09, 2022 - 01:44 UTC
Identified
We have identified an issue with an upstream DNS provider. Customers may see delays in board loading.
Posted Dec 09, 2022 - 01:28 UTC
Investigating
We are aware of an issue where boards are not loading and are currently investigating.
Posted Dec 08, 2022 - 22:52 UTC
This incident affected: Dashboard.